This project has moved and is read-only. For the latest updates, please go here.


Apr 20, 2014 at 6:12 PM

I really like your project, and I believe it would be very helpful for alot of people(professionally or just for fun).

Im quite a newbie when it comes to netduino and .Net. I have been programming PLCs an Scada systems for a while, and I`m trying to get my Netduino Plus to communicate with a Siemens S7 315 PLC, through Modbus TCP. This is a "just for fun" project, but it might get useful someday.

Anyway, I have downloaded "V2" folder and opened the solution "Cet.IO.DemoModbus_MF42", in visual studio 2010 express.
I have connected my Netduino Plus (FW 4.2) and when I try to debug the solution, I get the error "Device not found or cannot be opened - USB:Netduino"

In my Settings, the Netduino Plus is recognized as "USB:NetduinoPlus_NetduinoPlus".
This deviates with the error message, so my question is: How can I solve this issue, and debug/run your application?
Apr 21, 2014 at 1:20 PM

This has been solved!

I had to first swap to Emulator deployment, and then back to USB.
Anyway, this solved the problem I had, in addition to adding NetduinoPlus as reference in the startup project.